Support Center

Support / Method 1 / Manual & System Requirements<\/span>

Manual & System Requirements

Minimum System Requirements:

  • KONTAKT Player Or KONTAKT 6 Full Version 6.1.1 or higher
  • MacOS 10.12, 10.13, 10.14 or 10.15 (latest update), i5, 4 GB RAM
  • Windows 7, Windows 8, or Windows 10 (latest Service Pack), Intel Core i5 or equivalent CPU, 4 GB RAM

Recommended System Requirements

  • KONTAKT Player Or KONTAKT 6 Full Version 6.1.1 or higher
  • Mac OS X 10.12 and higher (latest update), 8 GB RAM Intel Core i5 or i7, i9
  • Windows 7, Windows 8, or Windows 10 (latest Service Pack), Intel Core i5 or equivalent CPU, 8 GB RAM

*Please note Native Access is required for the activation of our Kontakt based instruments

Can’t Find What You Are Looking For?
Get In Touch with us